Lỗi với native lib ở Hadoop 2.4.1

Mình gặp lỗi với native library ở Hadoop

Nguyên nhân:

– Source code được compile cho 32-bits, mình dùng 64 bits nên ko được.

Cách giải quyết:

1. Theo link sau thì mình đã thử setup path đến native libs nhg chưa được

2. Build từ source code

Làm theo hướng dẫn ở 3 site sau nhg vẫn chưa được

http://hadoop.apache.org/docs/current/hadoop-project-dist/hadoop-common/NativeLibraries.html

http://www.ercoppa.org/Linux-Compile-Hadoop-220-fix-Unable-to-load-native-hadoop-library.htm

http://tech.yipp.ca/linux/install-google-protocol-buffers-linux/

Ngày mai sẽ thử lại từ cách 1 đến cách 2 😦

Update 2014.09.18

Mình đã build thành công theo link dưới đây

http://vichargrave.com/create-a-hadoop-build-and-development-environment-for-hadoop/

Chú ý là nên dùng đúng Java mà Hadoop recommend (Oracle JDK 1.6)

Thực ra build xong rồi thì mình mới để ý là dự án của mình cần dùng Hadoop 1.2.1 chứ ko phải là Hadoop 2.4.1 nên build xong cũng để đấy chứ chưa dùng 😛

Advertisements

2 thoughts on “Lỗi với native lib ở Hadoop 2.4.1

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s